Managed WordPress

We have the plan to meet your needs.

Standard

  • 1 Site Hosted
  • 10 GB SSD Storage
  • Unlimited Bandwidth
  • 2 Core Processor
  • 1 GB Memory (RAM)
  • Shared (Low-contention)
  • Free Quick-Fix Support
  • Managed WordPress Updates

£14.95

£149 /Year ( 2 Months FREE )

Professional

  • 2 Sites Hosted
  • 20 GB SSD Storage
  • Unlimited Bandwidth
  • 2 Core Processor
  • 2 GB Memory (RAM)
  • Shared (Low-contention)
  • Free Quick-Fix Support
  • Managed WordPress Updates

£29.95

£299 /Year ( 2 Months FREE )

Business

  • 5 Sites Hosted
  • 30 GB SSD Storage
  • Unlimited Bandwidth
  • 2 Core Processor
  • 2 GB Memory (RAM)
  • Shared (Low-contention)
  • Free Quick-Fix Support
  • Managed WordPress Updates

£59.95

£599 /Year ( 2 Months FREE )

Enterprise

  • 5 Sites Hosted
  • 50 GB SSD Storage
  • Unlimited Bandwidth
  • 4 Core Processor
  • 8 GB Memory (RAM)
  • Dedicated VPS Environment
  • Free Quick-Fix Support
  • Managed WordPress Updates

£159.95

£1,599 /Year ( 2 Months FREE )

Free Setup
cPanel Servers
Free Comodo SSL Certs
UK Data Centre
PCI Compliant
Free Daily Backups
SFTP/SSH Access
DDoS Protection

Move to Chkserv

Move your sites to Chkserv for FREE.

An instant speed boost for your website.

  • Improving SEO and increasing conversions.
  • Page Caching for ultra-fast load times.
  • CloudFlare Compatibility.
  • Faster than Apache.
  • Lazyload.
lsws

Once payment has been successful, then account setup will be complete within a few minutes.

No. It’s good business practice to host your emails separately from your website.

No banned plugins. But note, that WordFence is known to cause some issues.

No contracts. Cancel and re-join anytime.

  • Server Security & Maintenance.
  • FREE WordPress Quick-Fixes ( Via ChkAid )
  • Managed WordPress Updates ( Core & Plugins only )
  • WordPress Transfers ( For the maximum sites aloud on your plan )

Should you wish to alter any PHP limits or settings you can do so by modifying the php.ini file.

Yes, our network is DDoS Protected.

  • PHP: 7.0, 7.1, 7.2 & 7.3
  • LiteSpeed ( 5.3.6 )
  • MariaDB ( 10.3 )
  • Git ( 2.19 )
  • WP-CLI ( 2.1 )